5play.ru / News / Chrome, Firefox and Edge browsers will be updated to version 100 soon. This may cause problems with the display of sites.

Chrome, Firefox and Edge browsers will be updated to version 100 soon. This may cause problems with the display of sites.

1 872
Chrome, Firefox and Edge browsers will be updated to version 100 soon. This may cause problems with the display of sites.
Newer versions of popular web browsers can cause site rendering errors. Their cause is the identification string of the User-Agent – it will turn from two-digit to three-digit.

The server uses the data sent to it to adapt sites and display media content normally. The user agent string allows web pages to recognize the browser being used and its version.

In tests conducted by Mozilla, User-Agent has been found to be capable of causing crashes and incompatibility issues for many web domains that are not suitable for recognizing 3-character user agent strings. It turned out that large sites are not without this problem. For example, on HBO Go, Bethesda, and Yahoo, errors such as browser support denied, 403s, as well as incorrect display and syntax parsing failures occurred.

Chrome, Firefox and Edge browsers will be updated to version 100 soon. This may cause problems with the display of sites.


Browser developers were aware of these issues, so they asked users to install pre-release versions of applications and test them.

Previously, similar crashes occurred with browser versions 10, when digital designations switched from single to double digits. It happened twelve years ago.

Application developers intend to take control of the situation if failures begin to occur regularly. For example, Firefox and Chrome may be temporarily left at version 99 until the problems are finally resolved.

The release of 100 versions of Chrome and Edge is scheduled for March 29, while Firefox will be available on May 3.
Login or register to post comments

Comments 0

There are no comments yet, but you can be the one to add the very first comment!